12th November 2019

Degraded performance on AWS server

Update - 15:33 (CEST)

The issue related to AWS has been resolved.

We are currently experiencing degraded performance in one of our AWS locations. We are in contact with them to have a fast resolution of the issue. For more information, you can access the AWS status page - https://status.aws.amazon.com

Update - 12:51 (CEST)

Some of the services are back to normal and Amazon still continues to have a fix for all the services affected. Please follow AWS status page (Europe) for any update - https://status.aws.amazon.com