18th November 2019

Degraded server performance

Server performance is normalizing and sites are coming online

We are still monitoring and investigating what was the cause for this incident.

Update 10:00

We are still experiencing degraded server performance

We are working on resolution and we will keep you updated.

The server performance is normalizing and sites are getting back online

We are still monitoring all systems to ensure normal operations.

Update: 07:45

We are currently experiencing server issues which may result in slow loading or unresponsive sites

We are working on resolution and we will keep you updated.

Last updated: 07:20