28th April 2020

E-mail Webmail login is timing out

We are currently experiencing issues with log into the webmail. We have reported it to the mail provider to fix

Update 29/04/2020 03:15 This is now resolved

Update 21:00 The mail provider has now implemented some mitigation measures in place to help with the problem. We continue to monitor this.