29th May 2020

E-mail 3rd party provider incident

We are currently experiencing issues with Webmail

We are experiencing issues logging into Webmail. IMAP and POP services are also affected. Our service provider’s operations team are aware of the issue and are working to repair the affected mail stores.

We will provide an update once we have additional information.

Time posted May 29, 18:19 UTC

Issue has been fixed

Our operations team has implemented a fix to lessen the load of the affected mailstores, users should expect to be able to log in again. We are still monitoring the issue.

Status: Monitoring

Last updated: May 28, 22:40 UTC

Issue has been fixed

Services are back to being fully operational, this incident is now resolved.

Last updated: May 29, 01:22 UTC